Engine stalls when warm

What's the MPG like? Can I use chip fat and veggie oil? What about LPG?

Moderator: Doone

Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Engine stalls when warm

Post by Tigmaster » Mon Apr 24, 2023 7:31 pm

Hi
First time on forum.
I have just purchased a 2000 2.5 V6.
It has a really good MOT history and passed in March with no issues.
Owner sorn the vehicle for the last few months as wasn’t using it over winter.
We did test drive it and all was okay. No over heating, gearbox all seemed to be ok.
On driving home after 30 minute drive I came off dual carriageway and stopped at a junction and it stalled whilst in drive.
It started straight away and off I went again. Until next junction where it stalled again.
When cold it starts straight away, idles around 1200 rpm and no issues with stalling.
When it gets up to temp it idles just under 750rpm in park or neutral.
When selecting D or R the revs drop below 500 and tries to stall unless I keep my foot on the throttle.
I have checked plugs & distributor cap all ok.
Air filter a bit grubby but not terrible.
I have ordered new plugs, air filter, oil filter.
I’m pretty certain it’s not a gearbox problem as it works ok including acceleration and kick down.
After a vast amount of research I was advised to check the idle control valve.
So I have stripped everything out to get to the valve.
7.2v at the switch plug.
11.2 ohms across the solenoid connections.
When switching on the solenoid opens and when turned off it closes although it can vary as to whether it takes 0-2 seconds to close.
Looks fairly clean inside and can’t really see how I can clean it.
Also tried removing fuel cap - no difference.
Has anyone got any advice please?

Also on the 1st photo there is a random hose with a u bend on the end that comes from the gearbox.
Is this supposed to be attached to anything? Or is it just a vent?

Regards
Sean
Attachments
931C9A65-0DC1-4F29-8C65-8462EA4B0B7E.png
F13CC5FA-99A2-45DB-8B05-BB5F0998B8D1.png
7B523B86-7D38-4CF0-9964-890BA374F792.png
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Mon Apr 24, 2023 9:37 pm

Welcome aboard!

I had a similar problem, turned out to be the BAC (Bypass Air Conditioner) valve right at the back of the engine. The valve is a bi-metallic type strip that controls the air flow using the coolant temperature, it worked fine when the engine was cold/cool but started to stall once the engine had been running awhile! Turned out that one of the coolant pipes had been squashed flat and there was no coolant/wrong amount flowing and hence the valve wasn't operating correctly according to engine temperature. It is in a right difficult position right at the back of the engine and not easy to reach even with the engine cover back plate removed. If you have the engine manual details on page 196.

Just noticed in the faulting section that this also causes "The idle speed to take along time to decrease", which I think you noticed as well.
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Mon Apr 24, 2023 10:07 pm

I don’t have any manuals yet.
Is there a pdf available as I am working blind at the moment.
I don’t suppose you have a picture of the said part so I know what to look for?
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Tue Apr 25, 2023 8:35 am

There is no PDF as its still in copyright and available from the shop https://bongoland.co.uk/product/bongo-w ... lumes-1-2/

Here are some pictures from the manual, item 9 on the first diagram righthand side, middle'ish;
IMG_20230425_082641.jpg
IMG_20230425_082750.jpg
IMG_20230425_082840.jpg
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Tue Apr 25, 2023 10:59 am

Thanks Geoff for the info.
That’s the part I have removed and checked so hopefully I am on the right path.
There are 2 valves in the V6 version.
1 is controlled by the solenoid and the other I presume is controlled by the temperature of the coolant?
I know the electric part works ok so need to investigate the temp side.
This might be failing when the temp increases and causing the stalling.
Although it could be the vacuum side of things.
If I understand correctly the idle speed is fine but when selecting D/R it is creating a load on the engine and it should be calling for an increase in revs by changing the air volume.
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Fri Apr 28, 2023 9:18 pm

Well the ICV is back on.
It all works fine when ignition turned on.
Cant find any vacuum leaks or damaged pipes
Changed plugs and air filter and made no difference.
I found out I had been incorrectly checking ATF in gearbox - engine not running.
With engine running I found it was missing 1 litre 😮
Filled to correct level but still stalling.
I did read this morning that it could have an air lock which might dissipate if I let it cool down and the fluid runs back out of the torque converter.
I have a fault code reader coming tomorrow so hope that finds a fault.
Otherwise I am going to have to pay someone to check the gearbox out or just get a 2nd hand box as it could be a damaged converter or solenoids.
I can’t imagine running a gbox with 1 litre missing will do it much good.
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Fri Apr 28, 2023 9:59 pm

If you have an OBDII fault reader coming, bad news, its not an OBDII system!
These vehicles apart from a few in the last year of production are Mazda's own OBD system, if you have a late version then there will be a standard OBDII port just to the left of the steering wheel under the dashboard. More likely your the old version with 4-digit flash code read the documents in the the Factsheet area of the club https://igmaynard.co.uk/download/diagnostics.pdf
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Fri Apr 28, 2023 10:44 pm

So can you not use the 16 pin to 17 pin adapter to use the reader?
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Sat Apr 29, 2023 9:22 am

You can use it but it won't work, the Protocol is different.
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Sat Apr 29, 2023 4:18 pm

As Geoff rightly advised the code reader doesn’t work.
However I have managed to read the code using a volt meter. P1521 VRIS Solenoid 1 Circuit
Removed centre panel and checked all the vacuum hoses. All seem to be ok.
Took connections off and checked resistance - no reading.
Took them off and one was open the other closed.
Placed 12v across them and nothing.
Looks like both solenoids are not working.
Could this be my problem when it gets hot and the revs drop as soon as I put in gear?
Do these control the fuel management?
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Sat Apr 29, 2023 4:35 pm

Yes the VRIS system is quite a complex operation see http://nephilim.customer.netspace.net.au/Jerry/vris.htm
if the solenoid is dead then quite likely to have all sorts of strange results, as temperature, power speed etc all have an effect on its settings!
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Sun Apr 30, 2023 10:50 am

Does this look right?
The front solenoid looks like it was set up wrong.
The vacuum pipe and the pipe to the actuator are both on the same connector. Surely this bypasses the solenoid and would constantly open the actuator?
Attachments
8C891506-D31D-4907-B9C1-9DC54460C16B.png
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Sun Apr 30, 2023 11:38 am

There are often three pipes, one a continuation of the vacuum feed and the other on the other side of the valve itself. Actual arrangement varies depending on the valve see images below and instructions for testing the VRIS Solenoid valve;
IMG_20230430_113549~2.jpg
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Tigmaster
Bongonaut
Posts: 30
Joined: Sat Apr 22, 2023 6:52 pm

Re: Engine stalls when warm

Post by Tigmaster » Sun Apr 30, 2023 11:49 am

Thanks Geoff
What I meant is that the right one is currently set up so there is a constant vacuum to the actuator as the pipes are connected and the valve would not make any difference.
The one on the left is correct but the solenoid is stuck open.
So both actuators are being opened when they should both be shut until the solenoids are switched on
User avatar
g8dhe
Supreme Being
Posts: 10217
Joined: Sun Apr 13, 2008 10:06 pm
Location: Worthing, West Sussex.
Contact:

Re: Engine stalls when warm

Post by g8dhe » Sun Apr 30, 2023 11:58 am

I can't tell from here, some of the solenoids are change over and not sure which combination is used for what.
Geoff
2001 Aero V6, AFT, full side conversion.
Image Spherical Visions
Post Reply

Return to “Bongo Fuel & Performance Issues”